Far Cry 4 - Valley of the Yetis (DLC 4)

Far Cry 4 - Valley of the Yetis (DLC 4)

  • Availability unavailable
  • Delivery Time Delivery in 1-24 hours
  • Language English
  • Platform PC
  • Version Region Free

This product is out of stock

We have the product "Far Cry 4 - Valley of the Yetis (DLC 4)" currently not in stock, which is why it can not be ordered. Please check back later.
NOTICE: Requires the base game Far Cry 4 in order to play. Activation key must be used on a valid Uplay account, requires internet connection.


ABOUT THE GAME
"Lost in an unforgiving Himalayan ridge after a helicopter crash, explore the frozen landscape to find tools, upgrade your camp and protect it from a dangerous cult when night falls.

In these new missions featuring single player and co-op action, you will never be alone as the yetis await their prey?"


SYSTEM REQUIREMENTS
Minimum
  • Supported 64-Bit OS: Windows? 7 (SP1) x64 / Windows? 8 x64 / Windows? 8.1 x64
  • Processor: 2.6 GHz Intel? Core i5-750 or 3.2 GHz AMD Phenom II X4 955
  • RAM: 4 GB
  • Video Card: NVIDIA GeForce GTX 460 or AMD Radeon HD5850 (1 GB VRAM)*
  • Direct X - Version 11
  • Sound Card: DirectX-compatible (5.1 surround sound recommended)
  • Peripherals Supported: Windows-compatible keyboard, mouse, optional controller (Xbox 360 Controller for Windows recommended)
  • Multiplayer: 256 kbps or faster broadband connection

Recommended
  • Supported 64-Bit OS: Windows? 7 (SP1) x64 / Windows? 8 x64 / Windows? 8.1 x64
  • Processor - 2.5 GHz Intel? Core i5-2400S or 4.0 GHz AMD FX-8350 or better
  • RAM: 8 GB
  • Video Card - NVIDIA GeForce GTX 680 or AMD Radeon R9 290X or better (2 GB VRAM)*
  • Direct X - Version 11
  • Sound Card - DirectX 9.0c compatible sound card with latest drive

* Supported Video Cards at Time of Release:
  • AMD Radeon HD 5850 / 6000 / 7000 / R7 / R9 series
  • NVIDIA? GeForce? GTX 460 / 500 / 600 / 700 / TITAN series

Note: Laptop versions of these cards may work but are NOT officially supported. This product supports 64-bit operating systems only. For the most up-to-date minimum requirement listings, please visit the FAQ on our support website at support.ubi.com

Show more details
€25.99 €29.99
€23.59 €59.99