9 Record(s)
We found results matching "ab" in 13 ms
Official Handsome Jack Doppelganger Pack DLC

Handsome Jack Doppelganger Pack DLC

  • Availability In Stock
  • Platform
  • Version

About This Content

Play as everyone’s favorite maniacal tyrant-in-training…or at least his body double. With the Handsome Jack Doppelganger Pack, use the power of your good looks and charm to distract your enemies into submission. Or, just cut them down to size with your witty banter. Or just shoot them. That works too.

Play as the hero(?) that Pandora and Elpis deserve.

 

System Requirements

PC

Minimum:

  • OS: Windows XP SP3
  • Processor: 2.4 GHz Dual Core Processor
  • Memory: 2048 MB RAM
  • Graphics: NVIDIA GeForce 8500 / ATI Radeon HD 2600
  • DirectX: Version 9.0
  • Hard Drive: 412 MB available space
  • Sound Card: DirectX 9 Compliant
  • Additional Notes: Other Requirements & Supports: Initial installation requires one time internet connection for Steam authentication; software installations required (included with the game) include Steam Client, directX 9, Microsoft .NET 4 Framework, Visual C++ Redistributable 2005, Visual C++ Redistributable 2008, Visual C++ Redistributable 2010, and AMD CPU Drivers (XP Only/AMD Only). Windows Imaging Component (Windows XP 64-Bit only)

Recommended:

  • OS: Windows XP SP3/Vista/Win 7/Win 8
  • Processor: 2.3 GHz Quad Core processor
  • Memory: 2048 MB RAM
  • Graphics: NVIDIA GeForce GTX 560 / ATI Radeon HD 5850
  • DirectX: Version 10
  • Hard Drive: 412 MB available space
  • Sound Card: DirectX 9.0 c Compliant

 

Mac

Minimum:

  • OS: 10.9.5 (Mavericks), 10.10 (Yosemite)
  • Processor: 2.2 GHz Intel Core 2 Duo (Dual-Core)
  • Memory: 4 GB RAM
  • Graphics: ATI Radeon HD 2600 / NVidia Geforce 8800 / Intel HD 4000
  • Hard Drive: 13 GB available space
  • Additional Notes: NOTICE: It is possible for Mac and PC to become out of sync during updates. Within this short time period, Mac users will only be able to play other Mac users.
  • NOTICE: This game is not supported on volumes formatted as Mac OS Extended (Case Sensitive)

 

Linux

Minimum:

  • OS: SteamOS, Ubuntu 14.04
  • Processor: Intel Core 2 Quad, AMD Phenom II X4
  • Memory: 4 GB RAM
  • Graphics: NVIDIA GeForce 260
  • Hard Drive: 13 GB available space
  • Additional Notes: Don't meet the above requirements? That doesn't mean your configuration wont run Borderlands: The Pre-Sequel. Visit the Borderlands: The Pre-Sequel community page to share your experience with other Linux players and learn about how to send bugs to Aspyr. Your feedback will help us improve Borderlands: The Pre-Sequel Linux and future AAA Linux releases!

 

CloseWelcome to Gamesdeal Sign In.

Not signed up yet?   Sign Up Now

Log in with a third party account:

  • Google

CloseWelcome to Gamesdeal Sign Up.

  • Email Address*

    Please enter a valid Email.

  • Password*

    5 to 16 letters, numbers, and special characters.

  • Confirm Password*

  • First Name* Last Name*

  • I have read and agreed to the  
    Subscribe to Gamesdeal Offers ,Contests&Newsletter.

Already have an Gamesdeal account?   Sign In Now

Log in with a third party account

  • Google

CloseForgot Password

Close

Prompt T698563:

The programe has been successfully submitted to the system

Close

Prompt T698563:

The programe has been successfully submitted to the system

Close

Prompt T698563:

The programe has been This is a warning ?

CloseSuccessful Registration

CloseSecurity verification