9 Record(s)
We found results matching "ab" in 13 ms
Official Warframe: Warrior Pack

Warframe: Warrior Pack

  • Availability In Stock
  • Platform
  • Version
NOTICE: This content requires the base game Warframe (free of charge) on Steam in order to play.


ABOUT THE GAME
The Warrior Pack is a great choice for a new player to get a quick start in Warframe. It will open up your choice of Warframes, weapons and equipment, allowing you to advance more quickly in the game.


KEY FEATURES
  • 500 Platinum to use toward new Warframes, Archwings, weapons, pets, and more

  • 60,000 Credits to assist in making new upgrades to your arsenal

  • 6 Random Mod Cards to instantly upgrade your inventory

  • 4 Rare Mod Cards to add hard-to-find modifications to your inventory

  • Affinity Booster and Credit Booster to quickly level up your Warframe, Archwing, and weapons for 3 days


SYSTEM REQUIREMENTS
Minimum :
  • OS: Windows XP SP 3 or higher
  • Processor: Intel Core 2 Duo e6400 or AMD Athlon x64 4000+
  • Memory: 2 GB RAM
  • Graphics: Nvidia GeForce 8600 GT or ATI Radeon HD 3600
  • DirectX?: 9.0c
  • Hard Drive: 10 GB HD space
  • Other Requirements: Broadband Internet connection


CloseWelcome to Goodoffer24 Sign In.

Not signed up yet?   Sign Up Now

Log in with a third party account:

  • Google

CloseWelcome to Goodoffer24 Sign Up.

  • Email Address*

    Please enter a valid Email.

  • Password*

    5 to 16 letters, numbers, and special characters.

  • Confirm Password*

  • First Name* Last Name*

  • I have read and agreed to the  
    Subscribe to Goodoffer24 Offers ,Contests&Newsletter.

Already have an Goodoffer24 account?   Sign In Now

Log in with a third party account

  • Google

CloseForgot Password

Close

Prompt T698563:

The programe has been successfully submitted to the system

Close

Prompt T698563:

The programe has been successfully submitted to the system

Close

Prompt T698563:

The programe has been This is a warning ?

CloseSuccessful Registration

Click here to set up your User Center

CloseSecurity verification